How to , and other stuff about linux, photo, php … Another blog just like others on internet

March 21, 2016

letsencrypt plesk problem

Filed under: Linux — Tags: , , — admin @ 4:58 pm

Well today a new problem.

I have try to install the letsencrypt  module on a plesk centos 6 server . That have python 2.6 and you will get a warning I think that is not working with python2.6 but the problem is other module.

The error’s look something like this

Fehler: Fehler bei der Installation des SSL-Zertifikats von Let’s Encrypt: Failed letsencrypt execution: /usr/local/psa/var/modules/letsencrypt/venv.gUBSl/lib/python2.6/site-packages/cryptography/ DeprecationWarning: Python 2.6 is no longer supported by the Python core team, please upgrade your Python.


Traceback (most recent call last):

File "/usr/local/psa/var/modules/letsencrypt/venv/bin/letsencrypt", line 11, in <module>


File "/usr/local/psa/var/modules/letsencrypt/venv.gUBSl/lib/python2.6/site-packages/letsencrypt/", line 1950, in main

plugins = plugins_disco.PluginsRegistry.find_all()

File "/usr/local/psa/var/modules/letsencrypt/venv.gUBSl/lib/python2.6/site-packages/letsencrypt/plugins/", line 168, in find_all

plugin_ep = PluginEntryPoint(entry_point)

File "/usr/local/psa/var/modules/letsencrypt/venv.gUBSl/lib/python2.6/site-packages/letsencrypt/plugins/", line 31, in __init__

self.plugin_cls = entry_point.load()

File "/usr/local/psa/var/modules/letsencrypt/venv.gUBSl/lib/python2.6/site-packages/pkg_resources/", line 2201, in load

self.require(*args, **kwargs)

File "/usr/local/psa/var/modules/letsencrypt/venv.gUBSl/lib/python2.6/site-packages/pkg_resources/", line 2218, in require

items = working_set.resolve(reqs, env, installer)

File "/usr/local/psa/var/modules/letsencrypt/venv.gUBSl/lib/python2.6/site-packages/pkg_resources/", line 835, in resolve

raise VersionConflict(dist, req).with_context(dependent_req)

ContextualVersionConflict: (cryptography 1.1 (/usr/local/psa/var/modules/letsencrypt/venv.gUBSl/lib/python2.6/site-packages), Requirement.parse(‘cryptography>=1.3’), set([‘PyOpenSSL’]))


The problem actually is the crypthography module.

So the fix is

cd /usr/local/psa/var/modules/letsencrypt/venv/bin

./pip install –upgrade cryptography


  1. Centos 6.6
    `yum install gcc libffi-devel python-devel openssl-devel`
    ‘source /usr/local/psa/var/modules/letsencrypt/venv.XYZ/bin/activate’
    ‘pip install –upgrade cffi’
    ‘pip install –upgrade cryptography’

    Comment by miguelitos — March 22, 2016 @ 5:25 am

  2. Great if there is another solution also .

    Comment by admin — March 25, 2016 @ 12:46 pm

RSS feed for comments on this post. TrackBack URL

Leave a comment

Powered by WordPress